Problemas PAYU Official WebSite
Incident Report for PayU Latam Status
Resolved
Estimado Cliente
Nuestra plataforma PayU esta operando normalmente , estamos en constante monitoreo del sistema para evitar incidentes futuros.
Posted Jun 11, 2019 - 10:46 GMT-05:00
Investigating
Desde las 08:30 GMT -5 , estamos presentando problemas en nuestra plataforma PayU Official WebSite. Estamos trabajando para dar una pronta solución al incidente.

Since 08:30 GMT -5 , we are presenting problems with our PayU Official WebSite Platform. We are working on the solution of the incident.
Posted Jun 11, 2019 - 09:12 GMT-05:00