PAYU PLATFORM DEGRADATION

Incident Report for PayU Latam Status

Resolved

Dear Customer,

As part of the ongoing updates to our platform, scheduled maintenance today a degradation was observed on some networks since 13:42 UTC -5 until 14:33UTC -5 The incident has been resolved and processing is now normal.
Posted Nov 13, 2025 - 14:49 GMT-05:00

Investigating

Dear Customer

Since 13:42 UTC -5 (Colombia's time) we are identifying troubles in transactional processing in our PAYU PLATFORM which could be generating a degradation of the service. Our technical team is evaluating the impact, and they are working to resolve the issue as soon as possible.

A High subset of our customers may be experiencing declined transactions, we apologize for any inconvenience this may be causing.



Sincerely,
PayU customer service.
Posted Nov 13, 2025 - 13:52 GMT-05:00
This incident affected: PayU (PayU Payments API, PayU Web Checkout).