Degradation with MERCHANT PANEL

Incident Report for PayU Latam Status

Resolved

Dear Customer,



Since 11:19 GMT-5 the incident has been resolved, MERCHANT PANEL in COLOMBIA for the PAYU platform is operational and functional



Sincerely,
PayU customer service.
Posted May 12, 2026 - 12:30 GMT-05:00

Investigating

Dear Customer,



Since 10:00 GMT - 5 we are experiencing problems with our Merchant Panel in LATAM for the PayU platform.


We are working together with the Support Team to get a quick solution. We apologize for any inconvenience this may be causing.

Sincerely,
PayU customer service.
Posted May 12, 2026 - 10:46 GMT-05:00
This incident affected: PayU (PayU Secure).