Incident with Payment Network PAGOEFECTIVO - PERÚ
Incident Report for PayU Latam Status
Resolved
Dear Customer,



The incident has been resolved, Pago Efectivo in Perú for the PayU platform is operating.



Sincerely,
PayU customer service.
Posted Oct 01, 2021 - 02:35 GMT-05:00
Investigating
Dear Customer,

Since 00:38 GMT -5 we are experiencing problems with the payment method PAGOEFECTIVO in PERÚ for PayU Platform. We are getting in touch with the provider to ask for incident's resolution.

Sincerely
Customer Service PayU.
Posted Oct 01, 2021 - 01:29 GMT-05:00
This incident affected: Perú Payment Processing (Pago Efectivo).