Degradation with Payment FISERV Mexico

Incident Report for PayU Latam Status

Resolved

Dear Customer,



Since 17:30 hs. the problem has been solved, FISERV in Mexico for the PAYU GPO Latam platform is operating normally.


Network´s Stability is confirmed from their end and transaction normality is evidenced.



Sincerely,
PayU customer service.
Posted Apr 28, 2025 - 17:52 GMT-05:00

Update

We are continuing to investigate this issue.
Posted Apr 28, 2025 - 14:50 GMT-05:00

Investigating

Dear Customer



Since 14:03 GMT - we are having problems with FISERV in Mexico for PayU platform, decrease in transactions , which indicates that we present a transactional degradation, however, the network does not present a total drop. We are working together with our Support Team to get a quick solution.



A SMALL subset of our customers may be experiencing declined transactions, we apologize for any inconvenience this may be causing.



Sincerely,
PayU customer service.
Posted Apr 28, 2025 - 14:45 GMT-05:00
This incident affected: México Payment Processing (Fiserv Mastercard, Fiserv Visa).