PSE-ACH HAS UPDATED ITS LIST OF BANKS

Incident Report for PayU Latam Status

Resolved

Dear Customer,

PSE-ACH has updated its list of banks and activated BANCOLOMBIA after completing maintenance.


Sincerely,
PayU Customer Service.
Posted Feb 26, 2026 - 03:01 GMT-05:00

Identified

Dear customer:


PSE-ACH has updated its list of banks, deactivating BANCOLOMBIA due to scheduled maintenance today.

Sincerely,
PayU Customer Service.
Posted Feb 25, 2026 - 22:12 GMT-05:00
This incident affected: Colombia Payment Processing (ACH-PSE, PSE AVANZA).